To Maximize Your Webinar Experience, Please Read Below

Mac Users: The latest version of Firefox is recommended--especially for webinars. Safari is a second choice and you must have the latest version.
Google Chrome is supported but is the least stable. Download the latest version of Firefox here.

PC/Microsoft Windows Users: The latest versions of Internet Explorer or Firefox are recommended for performance and security.
Google Chrome is supported but is the least stable. Download the latest version of Firefox here.

All Systems: The new Video Webinars do not require Adobe Flash Player.

There's More...

Check Your Bandwidth: Attendees should have upstream network speeds of 100+ Kbps. For live video, a minimum of 300+ Kbps is required. Test your connection speed with http://www.speedtest.net/

Java VM Software: In the unlikely event that you need to re-install or upgrade your Java VM software, we recommend using this link.

Firewalls: If your organization has high security settings, your IT staff should check access to make sure Internet Ports 80 and 1935 are open.

If You Need Support...

Please email tech support: support@psychotherapynetworker.org.